Migration du Bottin sur Debian 64-bit

Les jours à venir vont être un peu calme pour le Bottin car je passe le PC du Bottin en 64-bits et j’en ai aussi profité pour changer de disques (2x4To en RAID1 vs 2x1To en RAID1). Donc je pense que ça va me prendre pas mal de temps pour tout installer sur des disques vides et retrouver mes marques.

Je n’ose pas faire de prévisions, mais pour l’instant après quelques cafouillages, ça se présente pas trop mal :

J’avais en effet d’abord testé UNetbootin (à ne pas confondre avec le Bottin – lui aussi un peu deprecated :), pour comprendre que finalement il ne fallait pas l’utiliser (car il faut ensuite les CD Debian, donc aucun intérêt) mais plutôt passer par ici : Préparation des fichiers pour un amorçage avec une clé USB, (pour obtenir un système d’installation Debian directement sur la clé). On obtient une clé d’installation graphique (génial, c’est beau, la dernière fois que j’ai installé une Debian c’était entièrement en mode texte).

J’ai eut aussi quelques soucis avec la configuration du réseau (sans réseau c’est mort :), notamment avec les DNS Free que je ne trouvais plus (finalement sur mon autre PC il fallait chercher dans /run/interface/eth1.dhclient pour les obtenir, car /etc/resolv.conf ne les donne plus).

Ensuite c’est avec Grub que j’ai eut quelques soucis : j’avais déjà formaté mes 2 disques en RAID1, l’installateur Debian me les a bien reconnu (en /dev/md7, car je les ai formaté avant de quitter le confort de ma Debian 32-bits, sur laquelle j’avais déjà mes autres partitions RAID), mais dans les toutes dernières étapes de l’installation (j’ai trouvé une doc sur le site carnetdumaker.net) grub ne me propose pas de s’installer sur /dev/md7 comme je m’y attendais, mais sur l’un des /dev/sdx. Tant pis, vu la doc précédente, j’ai testé mais il plante. Finalement je l’ai installé sur /dev/sda1 (mon disque SSD que je ne souhaitais pas utiliser initialement, je ne rentre pas dans les détails, j’ai des disques extractibles, c’était pour un retour éventuel en arrière). Cette solution a le mérite de fonctionner : j’ai un système qui démarre.

J’ai donc un système 64-bits qui démarre sans clé de boot, mais assez minimaliste. En plus le serveur DNS était mal configuré. Du coup je l’ai changé dans /etc/resolv.conf (sic). Je m’attendais à un serveur Xorg opérationnel, mais non, avec cette clé USB (de 2Go) je n’avais que la version minimaliste (sinon il aurait fallu que je prenne la voiture pour aller en acheter une autre d’au moins 4Go, mes autres clés étant occupées, je l’ai joué à l’économie :)).

Donc voilà j’en suis là, j’ai un système Debian 64-bits sur 2 disques de 4To vides mais fonctionnels en RAID1 (j’ai vérifié par un # cat /proc/mdstat) il va falloir que je joue de l’apt-get pendant un moment pour retrouver mon système d’avant, va falloir être patient.

Follow / Contact us: