Des News

Je suis toujours là 🙂

Et voilà où j’en suis aujourd’hui (30.06.2019) :

Pour rappel, j’ai changé de carte mère (MSI B450 Gaming pro carbon AC vs ASUS), de processeur (AMD RYZEN 7 2700X vs INTEL), de mémoire (32Go vs 6Go), et de carte graphique (toujours Nvidia mais upgrade en GeForce RTX 2070 vs ma vieillissante – mais toujours fidèle GTX 260), le reste (disques, boîtier, alim, ventilateurs, moniteur) étant récupéré.

Au démarrage sous Linux c’est la catastrophe : je perd mon disque dur principal en RAID1 – peut-être dans une fausse manipulation de ma part, je n’en sais rien (très étonnant, une partie plutôt nébuleuse avec des changements de noms de périphériques dus aux clés USB insérées et retirées, la découverte d’un disque vide et l’autre RAID en train de s’aligner dessus).

Ensuite, je galère (pas moyen de réactiver l’accélération graphique) – notamment parce que je suis « rouillé » (j’ai oublié pas mal de choses puisque voila pas mal d’années que je mettais à jour ma Debian Sid sans trop de problèmes), je dois tout reprendre à zéro, à commencer par refaire marcher l’accélération graphique.

J’ai une configuration exotique : un écran HP LP3065 (2560×1600 de 30″) nécessitant du DualLink (2 prises DVI requises pour fonctionner). J’avais prévu le coup (partiellement :)) lors de mon achat en achetant 2 types de cordons-adaptateurs (2 adaptateurs DisplayPort vers DVI + 1 HDMI vers DVI au cas où il y aurait un souci avec le DisplayPort), car je savais que la nouvelle carte graphique n’avait pas de sortie DVI.

Après de nombreuses tests et recherches, la conclusion est que cet écran ne peut fonctionner correctement sans une carte graphique et un driver supportant le DualLink. Les derniers pilotes Nvidia (> v.390.116) ne le supportent plus (un développeur de chez Nvidia précise que seul le driver nv / nouveau supporte l’option DualLink, mais de toute façon celui-ci ne supporte pas encore ma nouvelle carte graphique), et l’ancien pilote Nvidia (v.390.116) n’est pas compatible avec ma nouvelle carte graphique. Conclusion, je ne peux pas utiliser ma nouvelle carte graphique avec cet écran.

Si je veux utiliser ma nouvelle carte graphique je vais donc devoir acheter un autre écran.
Dans l’attente, j’ai inséré mon ancienne carte graphique GTX260 dans l’autre port PCI, branché dessus mon écran et réinstallé l’accélération graphique. J’avais envisagé d’utiliser les 2 cartes graphiques en parallèle (moyennant l’upgrade de mon alimentation pour avoir suffisamment de cordons d’alimentation) mais ça ne servira à rien car les pilotes nvidia des 2 cartes sont différents, je suis à peu près certain que ça ne fonctionnera pas (je doute qu’ils puissent coexister en mémoire, et le pilote nvidia ne s’installe pas s’il détecte le pilote nouveau en mémoire).

Voilà pour la partie matériel, un bon jalon franchi (très long car je voulais tout tenter pour récupérer mon écran actuel, mais ce n’est plus possible).

J’ai aussi pu récupérer partiellement mes données sur une ancienne sauvegarde (malgré mes ennuis, j’ai une bonne étoile).
En ce moment je m’emploi à restaurer mes marques, mes logiciels et mes données.

Donc – sauf nouveau souci imprévu, ce n’est qu’une question d’une (si optimiste) ou deux (si pessimiste) semaines pour que je reprenne à peu près où j’en étais avant ces soucis.

Dans l’attente, j’ai créé et continue à mettre à jour un WIKI sur mon installation pour éviter de me reposer les mêmes questions à chaque fois (ma mémoire ne s’arrange pas). Si ça vous intéresse, ça se passe ici : trucs persos.

Bon Dimanche à vous.

Comments are closed.